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Preparation Installation and Maintenance Guide
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Preparation

This guide provides the information you need to install Sage Timberline Enterprise 
on your network—including system requirements, configuration instructions for 
the prerequisite software, and instructions for creating your company’s database. 
You’ll find the following sections in this guide:

This Preparation section gives you an installation checklist to keep track of 
your progress; the system requirements; and instructions for configuring your 
network. 

The Server Installation section walks you through each of the steps for 
installing Microsoft SQL Server, IIS, Sage Timberline Enterprise, and the 
additional Payroll and Estimating modules on the server.

The Server Configuration section shows you how to activate your licenses, set 
up administrators, and get started with a sample database. It also gives you the 
information you need to start developing a security plan for your company’s 
business database.

The Workstation Installation section walks you through setting up client 
workstations.

In the System Maintenance section, learn about the routine maintenance tasks 
you’ll perform on your Sage Timberline Enterprise system.

Read through this guide carefully and make sure you have all of the components 
necessary to ensure a successful installation.

This guide and related materials will be updated periodically with new information 
and posted on the Sage Customer Portal.

Revision History

Date Revised by Comments

02/02/10 SD Initial Draft

02/18/10 SD Updates based on reviewer feedback.

4/1/2010 AG Revisions

06/24/10 AG
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Installation Checklist Sage Timberline Enterprise
Installation Checklist

Complete these steps to install Sage Timberline Enterprise on a client/server 
network.

Task Information

❑ Review the system specifications for Sage Timberline Enterprise and 
complete any necessary upgrades.

page 7

❑ Prepare your hardware and network environment. page 15

❑ Determine the location for your database, spools, and attachments 
folders.

page 17

❑ Install Microsoft SQL Server 2008 and configure it to work with Sage 
Timberline Enterprise.

page 22

❑ Install and configure Microsoft Internet Information Services. page 43

❑ Install Sage Timberline Enterprise server software. page 47

❑ Install Payroll (optional). page 50

❑ Install Estimating and License Manager (optional). page 55

❑ Run the Sage System Administration Configuration Wizard. page 64

❑ Activate Your Sage Timberline Enterprise Licenses. page 71

❑ Set up a sample database and configure user access. page 73

❑ Develop your security plan. page 81

❑ Set up roles, features, and users in Sage System Administration. page 85

❑ Install Sage Timberline Enterprise client software. page 92

❑ Test the installation by opening Sage Timberline Enterprise on a 
workstation.

page 101

❑ Check for Sage Timberline Enterprise updates. page 117
6 © 2010 Sage Software, Inc.
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System Requirements
The performance of your Sage Timberline Enterprise system depends on having 
sufficient resources, including processor speed, memory, hard drive capacity, disk 
I/O, and network bandwidth.

Below are the minimum requirements for installing Sage Timberline Enterprise on 
your network. Note that other software products, including the operating system, 
also have minimum requirements which you will need to consider alongside those 
for Sage Timberline Enterprise.

Review your overall system infrastructure needs to ensure that your hardware and 
software have the resources necessary to meet your business demands. If you are 
considering obtaining new servers for Sage Timberline Enterprise or any of its 
components, request the Sage Timberline Enterprise Server Buying Guide from 
your business parter.

Network Requirements
Your network must meet the following requirements.

You must install Sage Timberline Enterprise on a server that is a member of a 
Windows domain (Windows Server 2003, 2008, or 2008 R2). 

Do not install Sage Timberline Enterprise on your domain controller.

If you have enabled a firewall on the server that will hold 
Sage Timberline Enterprise and SQL Server, you must configure it as follows 
to allow access to and from the workstations.

Allow HTTP and HTTPS incoming traffic (ports 80 and 443). 

Allow HTTPS outgoing traffic (port 443) to the outside Internet. (This is a 
requirement of the Entitlement Service.) 

Allow the port used by the SQL Server Instance. If you use only one SQL 
Server instance on the server, in most cases this is port 1433. If you have 
multiple named instances, the firewall ports are set dynamically, or you  may 
want to configure a fixed port.

You must have Internet connectivity for license activation. Once licenses are 
activated you do not have to remain connected to the Internet, but other 
frequently performed functions such as software updates, Payroll updates, and 
email require connectivity.

You can install Sage Timberline Enterprise on a different server than the 
database server. If you do this, you must set up Active Directory as described 
on page 15, step 4.

You can set up Sage Timberline Enterprise on a virtual server, and you can 
access it through a terminal server.
© 2010 Sage Software, Inc. 7
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Supported Protocols

You must have either TCP/IP (Transmission Control Protocol/Internet Protocol) or 
RDP 6.1 (Remote Display Protocol) on your network.

Servers

Server Operating Systems

These operating systems are supported for Sage Timberline Enterprise production 
servers:

NOTE:  Windows Small Business Server is not a supported operating system for 
Sage Timberline Enterprise servers.

Minimum Server Hardware Specifications

Following are the minimum hardware requirements for servers in a production 
environment.

Operating System Edition/Version Service Pack

Windows Server 2008 (x86/x64) Standard, Enterprise SP2

Windows Server 2008 R2 (x64 only) Standard, Enterprise

Windows Server 2003 Standard, Enterprise SP2

Windows Server 2003 R2 Stardard, Enterprise SP2

Item Minimum Notes

Processor 
speed

Quad-Core, 
1.8Ghz Xeon 
or equivalent

Processor speed is important on both the server and 
workstation. The majority of Sage Timberline 
Enterprise processing occurs on the workstation, but 
in future releases, the server will take on additional 
processing duties. 

Random Access 
Memory (RAM)

4 GB RAM System performance is directly affected by the 
amount of RAM on the server. We recommend that 
you install as much RAM as possible. 
If you plan to use more than 4 GB RAM, you will 
need to use a 64-bit operating system to take 
advantage of the greater memory.
If you plan to run terminal services as well as Sage 
Timberline Enterprise on the same server, you need 
more than 4 GB RAM.  See the section 
“Recommendations for Sage Timberline Enterprise 
Servers.”
8 © 2010 Sage Software, Inc.
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Recommendations for Sage Timberline Enterprise 
Servers

If you plan to purchase a server to use with Sage Timberline Enterprise, we strongly 
recommend that you select Windows Server 2008 R2 for your operating system 
because of its support for RAM configurations greater than 4GB. Ask your business 
partner for a copy of the Sage Timberline Enterprise Server Buying Guide to see 
more detailed recommendations.

Terminal Servers

If you will use Remote Desktop Services (terminal services) with 
Sage Timberline Enterprise, you must consider the server resources required for the 
added client sessions on the terminal server in addition to the server processing 
needs of Sage Timberline Enterprise and SQL Server. We recommend Windows 
Server 2008 R2 because of its support for RAM configurations greater than 4 GB.

Virtual Servers

You can install Sage Timberline Enterprise on a virtual machine. The virtual 
machine must meet the operating system and configuration requirements for server 
installations of Sage Timberline Enterprise. To accommodate this, the host 
hardware may require more resources than the minimum to support the overhead 
associated with running the host operating system and other applications or virtual 
machines. Consider increasing the CPU speed, amount of RAM, hard disk speed, 
and network bandwidth to support this configuration. If an issue is discovered while 
using a virtual machine and customer support is not able to reproduce it in a non-
virtual environment, work with your business partner or virtual machine 
manufacturer to resolve the issue.

Free Disk 
Space

10 GB for Sage Timberline Enterprise and SQL Server without Payroll.
12 GB for Sage Timberline Enterprise, SQL Server, and Payroll.
These amounts include 5 GB free space for your database. 
Additionally, you should allow for at least 10 GB free space for 
database growth in the future. 
We strongly recommend that you configure your system with 
redundant disk arrays (RAID), and that you separate the system and 
data files onto different RAID arrays. This can protect you from loss of 
data due to failed hard drives, and can also maximize performance.

Screen 
resolution

1024 x 768 Any computer on which you plan to use more than 
one monitor or a higher screen resolution must have 
a video card sufficient to support the greater 
requirements.

DVD drive Required for installation of Sage Timberline Enterprise.

Item Minimum Notes
© 2010 Sage Software, Inc. 9



System Requirements Sage Timberline Enterprise
NOTE:  If you use a USB drive on a virtual machine, you may need to obtain third-party 
hardware or software such as AnywhereUSB.

Estimating License Manager Server

If you plan to install Estimating and you will use License Manager to manage your 
concurrent uses of the software, you must designate one computer as a license 
server.  The license server can be the same server as your Estimating server if you 
wish—but it cannot be a terminal server. The License Manager server must have a 
fixed IP address. 

If the license server is a workstation, the workstation must always be on. It cannot 
be restarted like a typical workstation because all Estimating workstations depend 
on this machine for licenses.

NOTE:  When you first install License Manager on the server, the server and all 
workstations that will use Estimating must be on the same subnet. After you install License 
Manager you can move workstations to a different subnet if you need to. For more 
information, check the Sentinel License Manager help and accompanying documentation.

Required Supporting Software on the Server
The following are third-party components required by Sage Timberline Enterprise. 
You must install these components on your system before you can install Sage 
Timberline Enterprise. 

Microsoft SQL Server 2008 SP1

You must obtain a license for SQL Server 2008 and apply Service Pack 1 to the 
instance that hosts Sage Timberline Enterprise. We recommend that you also install 
Cumulative Update 7 for Service Pack 1 (see page 36).

Either the Standard or Enterprise editions of SQL Server are supported, and 32-bit 
or 64-bit versions are acceptable. SQL Server Express and the Workgroup edition 
of SQL Server are not supported for use with Sage Timberline Enterprise. 

You can install Microsoft SQL Server on a different server than Sage Timberline 
Enterprise.  This guide lists some configuration requirements for that scenario at the 
relevant points.

Microsoft Internet Information Services (IIS)

Sage Timberline Enterprise requires IIS. If you install Sage Timberline Enterprise 
on a different server than the database server, install IIS on the server with 
Sage Timberline Enterprise.

Installation details for IIS are provided in the section on installing IIS starting on 
page 43. Your operating system determines which version of IIS you install.

Windows Server 2008 or Windows Server 2008 R2 come with IIS 7.0. 
10 © 2010 Sage Software, Inc.
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System Requirements Installation and Maintenance Guide
Windows Server 2003 comes with IIS 6.0.

Microsoft Office 2007 with Service Pack 2

Sage Timberline Enterprise integrates with the following Microsoft Office 2007 
applications:

Excel is used to integrate with worksheets in Job Management and financial 
statements in General Ledger.

Outlook is required for sending emails, such as transmittals in Job Management.

If you plan to use the Excel or email integration features, you must install Microsoft 
Office 2007 with Service Pack 2 on workstations. (This is also true for terminal 
server uses.) If Microsoft Office 2007 is not present at the time you install Sage 
Timberline Enterprise on a computer, the installation routine skips installing the 
Excel integration feature. If you plan to use Excel integration later, you will need to 
install this feature at a later time.

NOTE:  Sage Timberline Enterprise requires that Service Pack 2 or greater be applied to 
Microsoft Office 2007. The integration does not currently work with the Beta version of 
Microsoft Office 2010.

Workstations

Workstation Operating Systems

These operating systems are supported for Sage Timberline Enterprise 
workstations.

Minimum Workstation Hardware Specifications

Following are the minimum hardware requirements for workstations.

Operating System Edition Service Pack

Windows 7 (x86 and x64) Ultimate, Enterprise, Professional

Windows Vista (x86 and x64) Ultimate, Business SP2

Windows XP (x86) Professional SP3

Item Minimum Notes

Processor 
speed

Dual core, 
2.4 GHz 

Processor speed is important on both the server 
and workstation. The majority of Sage Timberline 
Enterprise processing occurs on the workstation, 
but in future releases, the server will take on 
additional processing duties. 
© 2010 Sage Software, Inc. 11
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Random 
Access Memory 
(RAM)

4 GB RAM 
(Windows 7 or 
Windows Vista)
2 GB RAM 
(Windows XP)

System performance is directly affected by the 
amount of RAM. We recommend that you install 
as much RAM as possible. 
Windows 7 and Vista use large amounts of 
memory, so we recommend that you have more 
RAM on these types of machines.

Hard drive 
space

750 MB for Sage Timberline Enterprise only.
2 GB for Sage Timberline Enterprise and Payroll.

Screen 
resolution

1024 x 768 Any computer on which you plan to use more 
than one monitor or a higher screen resolution 
must have a video card sufficient to support the 
greater requirements.

Printer Use a Microsoft certified print driver.

Item Minimum Notes
12 © 2010 Sage Software, Inc.
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Additional Components Installed Automatically
The following are third-party components required by Sage Timberline Enterprise 
that are included as part of the installation process if they do not already exist on 
your machine. This information is only for your reference. You do not need to 
obtain these components separately.

Component Version and Notes

Microsoft Visual C++Runtime 9.0 SP1

Microsoft .NET Framework .NET 3.5 SP1

Microsoft Management Console (MMC) 3.0

VSTO Runtime 3.0

Infragistics 2008 WPF Vol. 1
2008 Vol. 2 
2007 Vol. 3

Aatrix Installed for 1099 forms used by Accounts 
Payable and for other forms used by the 
optional Payroll module.
© 2010 Sage Software, Inc. 13
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Prepare Your Hardware and Network 
Environment

Complete these tasks to prepare your network environment for 
Sage Timberline Enterprise installation.

1. Verify that all servers and workstations meet the minimum hardware and 
operating system requirements as outlined in the previous section.

2. If you do not have a Windows domain set up on your network, create a domain 
now and configure the Active Directory. Consider the following:

All Sage Timberline Enterprise servers, workstations, and users must be set 
up in Active Directory with access to this domain.

The server that functions as your domain controller cannot be the same as 
the Sage Timberline Enterprise server. You may need to obtain a new server 
or set up a virtual machine environment for Sage Timberline Enterprise.

3. Decide whether your employees will access Sage Timberline Enterprise 
through a terminal server. If so, will the terminal server also be the application 
server, or will you have separate servers for each function?  Obtain the 
necessary servers and configure them on your domain. (If you will use 
Estimating License Manager, the terminal server cannot be the license server.)

4. If you plan to install Sage Timberline Enterprise on a different server than the 
database server, you must set delegation correctly in Active Directory.

a. Log on to the domain controller as domain administrator, and open 
Active Directory Users and Computers.

b. Locate the computer object for the Sage Timberline Enterprise server. 
Right-click the computer and select Properties.

c. Click the Delegation tab, and select the option Trust this computer for 
delegation to any service (Kerberos only).  Click OK. 

5. Designate at least one person to be the system administrator for 
Sage Timberline Enterprise. Considering the following: 

The administrator is the person who will configure Sage System 
Administration, including creating and configuring the database, granting 
access to software features, and assigning users to roles.

The Sage Timberline Enterprise administrator is also a SQL Server system 
administrator for the instance on which you configure Sage Timberline 
Enterprise.

The Sage Timberline Enterprise administrator must be able to log on to the 
server with Administrator privileges in order to open Sage System 
Administration.
© 2010 Sage Software, Inc. 15
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6. Configure your firewall settings.

If you have enabled a firewall on your Sage Timberline Enterprise server, 
you must configure it to allow HTTP and HTTPS incoming traffic (ports 80 
and 443). You must also allow HTTPS outgoing traffic (port 443) to the 
outside Internet (Entitlement Service Requirement). 

If you use only one SQL Server named instance on the server, in most cases 
it uses port 1433. Edit your firewall exceptions to allow port 1433 (if using 
the default settings) or whichever port you selected for the instance. If you 
have multiple named instances, the firewall ports are set dynamically. You 
may want to configure a fixed port for use with your firewall. For more 
information, see this article:
http://msdn.microsoft.com/en-us/library/cc646023.aspx.

7. Verify your Internet connection. You must have Internet connectivity for license 
activation. Once licenses are activated you do not have to remain connected to 
the Internet, but other frequently performed functions such as software updates, 
Payroll updates, and e-mail require connectivity.
16 © 2010 Sage Software, Inc.
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Determine the Location of Data and Shared 
Folders

Sage Timberline Enterprise and SQL Server will access certain folders that store 
files related to your databases.  You specify the location of these folders during 
installation. You should decide upon the location of these folders now based on your 
network and security requirements. 

The folders you will create are as follows:

Default Data and Log folder for SQL—This is the default location for all 
databases and log files associated with a given SQL Server instance. 

Attachments folder—This location stores files that you associate with records 
in Sage Timberline Enterprise. For example, you might have blueprint drawings 
attached to a job. We recommend that you have a separate Attachments folder 
for each database that you set up in Sage Timberline Enterprise.

Spool folder—This location stores print output files from reports if you send 
them to the print spool. We recommend that you have a separate Spool folder 
for each database that you set up in Sage Timberline Enterprise.
© 2010 Sage Software, Inc. 17
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Default Data and Log Folder
Create the folder that will hold your data and logs before you install SQL Server, 
because you will specify its location during installation. This folder should not be 
on the root of a drive. (For example, do not specify it as simply C:\. A common 
practice is to place these folders inside a parent folder, such as the appropriate 
subdirectory of C:\ProgramData.)

SQL Server requires that the data and log files be stored on a physical drive located 
on the same machine as the SQL Server instance. The drive on which these folders 
are stored must have sufficient space to hold your database as it grows.

WARNING:  When you install SQL Server, you see a default folder path for data and log 
files, but you must change it to the location you set up for your default data and log files. 

The permissions on these folders must allow access to SQL Server administrators 
as well as Sage Timberline Enterprise administrators. Follow these steps:

1. Create the default data and log folder in the location you determine, which must 
be on the same physical machine as the SQL Server instance.

2. Open the Properties window for the folder and click the Security tab. (The 
steps to do this differ according to your Windows operating system.  Consult the 
Windows Help topic on changing folder properties.)

3. Add the appropriate administrator groups or individuals to the permissions list. 
18 © 2010 Sage Software, Inc.
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Attachments and Spool Folders
Create the Attachments and Spool folders before you set up databases in Sage 
System Administration, because you will specify the location of these folders 
during database setup.

If you will have multiple company databases, we recommend that you create 
separate Attachments and Spool folders for each database. This prevents users of 
one database from having access to attachments and spool files from another 
database.

These folders should not be on the root of a drive. For example, do not specify them 
as simply C:\Attachments or C:\Spool. A common practice is to place these folders 
inside a parent folder, such as the appropriate subdirectory of C:\ProgramData..

You must share the Attachments and Spool folders with all users of the company 
database to which the folders correspond. (Sage Timberline Enterprise users who 
do not need to access attachments or spool files do not need this access.)

NOTE:  Consider creating Active Directory groups for your Sage Timberline Enterprise 
users so that you can add the group to the folder permissions. This facilitates security 
maintenance by letting you control group membership in Active Directly only.

To configure the Attachments and Spool folders, follow these steps. 

1. Create the Attachments and Spool folders in the location you determine. 

2. Open the Properties window for each folder and click the Sharing tab. (The 
steps to do this differ according to your Windows operating system.  Consult the 
Windows Help topic on changing folder properties.)

3. Share the folder.

4. Set the permissions on the sharing to include each of the users with whom you 
want to share the folder. 
© 2010 Sage Software, Inc. 19
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Server Installation

This section guides you through the server installation steps for 
Sage Timberline Enterprise and related components. You should already have 
completed all of the steps in the Preparation section.

This section includes the following procedures:

Install and configure Microsoft SQL Server, starting on page 22.

Install and configure Internet Information Services, starting on page 43.

Install Sage Timberline Enterprise on the server, starting on page 47.

Install Payroll on the server, starting on page 50.

Install Estimating, starting on page 55.
© 2010 Sage Software, Inc. 21
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Install  Microsoft SQL Server 2008

You must install Microsoft SQL Server 2008 (Service Pack 1), specify the default 
database location, and configure it to use TCP/IP before you install 
Sage Timberline Enterprise. 

You may already have SQL Server installed. If so, confirm that you have the correct 
version, upgrade if necessary, and configure it for Sage Timberline Enterprise.

For more information on SQL Server, visit Microsoft’s Web site:
http://msdn.microsoft.com/en-us/sqlserver/default.aspx.

Before you Begin
Complete these tasks before you begin the installation of SQL Server.

Decide on a SQL Server administrator password. Make note of this password, 
as you will need it to perform SQL Server administrative tasks. 

Have your product key for SQL Server available. (You may not have a product 
key if you obtained SQL Server as a bundled product with Sage Timberline 
Enterprise.)

Verify your firewall settings, as described below.

Decide which SQL Server instance you will use (see considerations on the next 
page). 

Verify your Firewall Settings
You should have already configured your firewall as described in the section 
“Prepare Your Hardware and Network Environment” on page 15. If your firewall is 
not configured correctly when you install SQL Server, you may not be able to 
establish communication between the server and clients. 

If you use only one SQL Server instance on the server, in most cases it will use port 
1433 for SQL Server traffic. If you have multiple named instances, the firewall 
ports are set dynamically. You may want to configure a fixed port for use with your 
firewall, for security. 

To allow incoming SQL traffic to access your server in a client-server environment, 
you must edit your firewall exceptions to allow port 1433 (if using the default 
settings) or whichever port you selected for the instance. 

For more information, see this article
http://msdn.microsoft.com/en-us/library/cc646023.aspx. 
22 © 2010 Sage Software, Inc.
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Decide Which SQL Server Instance You Will Use
Each time you install SQL Server, you create an instance, or a copy of SQL Server 
running on the computer. Each computer has a single default instance, and you can 
add additional named instances if you want. 

Before you install SQL Server to work with Sage Timberline Enterprise, decide 
whether to use the default instance or a named instance. This table helps you 
compare these two options:

Using the Default Instance

Results in the simplest installation if you have no other applications running on SQL 
Server.

Requires you to grant SQL Server administrative privileges to the Sage System 
Administrator, opening all databases (regardless of associated application) to that 
administrator.

Requires that all SQL applications running on the default instance be compatible with 
SQL Server 2008 Service Pack 1.

Using a Named Instance

Allows you to keep database access and security for other applications separate from 
Sage Timberline Enterprise databases.

May require you to open additional firewall ports to enable SQL Server communication 
with the client.

Allows you to limit administrative access to databases for applications other than 
Sage Timberline Enterprise. All Sage system administrators also have administrator 
permissions in SQL Server for the Sage Timberline Enterprise instance.

Requires additional resources for each added instance on the computer. Consider using 
the default instance if application performance is a concern.

Requires that all SQL applications running on that instance be compatible with SQL 
Server 2008 Service Pack 1.
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Install SQL Server 2008
1. Insert the SQL Server 2008 DVD. The installation should start automatically.  

If it does not, browse to the DVD drive and double-click Setup.exe.

2. If you see a message about known compatibility issues, click Run program. 
(This message simply reminds you to install Service Pack 1, which you will do 
as part of this procedure.)

3. If you are asked to install prerequisites, click OK for each message about 
prerequisites. 

NOTE:  You may need to download some prerequisites to install them. The downloads are 
available from www.microsoft.com. 

4. If you are prompted to install Windows updates, click OK.

5. If you are prompted to restart the computer after installing updates, close any 
open programs and click Restart Now before continuing.
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6. After restarting the computer, double-click Setup.exe again. The SQL Server 
Installation window opens.

7. In the left panel, click Installation. 

8. Click New SQL Server stand-alone installation or add features to an 
existing installation.
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9. If you see the message about known compatibility messages again, click Run 
program.

10. The Setup Support Rules window is displayed. If any problems appear here, 
they must be corrected before you can continue. If the operation completes 
successfully, click OK.
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11. In the Product key window, enter the product key for your SQL Server 
software, and then click Next.

NOTE:  Your product key may already be present if you obtained SQL Server as part of a 
bundle with Sage Timberline Enterprise.
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12. In the License Terms window, click I accept the license terms, and then click 
Next.

13. In the Setup Support Files window, click Install. 

NOTE:  If you see a warning about the firewall, see “Verify your Firewall Settings” on 
page 22.
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14. Click Next to proceed to the Feature Selection window. Select Database 
Engine Services, Management Tools - Basic, and Management Tools - 
Complete, as shown here:

NOTE:  You can select additional features if you wish.  The features shown are the 
minimum required.

15. Click Next to proceed to the Instance Configuration window, and select either 
Default instance or Named instance. If you select a named instance, type an 
instance name (up to 16 characters and beginning with a letter). 
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NOTE:  If you are unsure whether to use a default or named instance, see “Decide Which 
SQL Server Instance You Will Use” on page 23.

16. Click Next to proceed to the Disk Space Requirements window.
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17. Click Next to proceed to the Server Configuration window. 

18. Click Use the same account for all SQL Server services. 

19. Select the Account Name of NT Authority\Network Service and click OK.

20. Verify that each service shows a Startup Type of Automatic. 

21. Click Next to proceed to the Database Configuration window. 
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22. Select Mixed Mode (SQL Server authentication and Windows 
authentication).

23. Enter a password for the built-in SQL Server system administrator account. 

WARNING:  Make note of this password, as you must have it in order to perform 
administrative functions within SQL Server. 

24. Click Add Current User to add yourself as a SQL Server administrator. To add 
additional users, click Add and enter the names. Your Sage system 
administrators must also be SQL Server administrators.

NOTE:  Consider adding the local administrators group as administrators for this instance. 
To add this group, click Add, type \\server\Administrators, and then click OK. 

25. Click Next to proceed to the Error and Usage Reporting window.
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NOTE:  Depending upon whether you selected other options in step 14, you may see 
additional screens at this point.  Continue through the selections until you see the screen 
shown here.

26. Select a reporting option if you want to send reports to Microsoft. Click Next to 
proceed to the Installation Rules window.
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27. Confirm that the installation process will not be blocked, and then click Next to 
proceed to the Ready to Install window.

28. Click Install to start the installation.
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29. When the installation is complete, the Installation Progress window shows 
that it completed successfully.

30. Click Next.

31. Click Close.
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32. In the SQL Server Installation Center window, select Search for product 
updates.

33. Follow the prompts to install any necessary updates. 

34. Restart your computer.

Install Service Pack 1 for SQL Server 2008
When you run the installation routine for Service Pack 1, the process applies 
Service Pack 1 only to the instance (named or default) that you specify.  If you have 
more than 1 instance running on your computer, be sure to apply Service Pack 1 to 
the instance supporting Sage Timberline Enterprise. (You can apply it to other 
instances as needed.)  SQL Server 2008 Service Pack 1 is required to run 
Sage Timberline Enterprise. 

If you installed updates as recommended in the step 33 above, you should already 
have this service pack installed.

Confirm That Service Pack 1 is Installed

1. Select Start > All Programs > Microsoft SQL Server 2008 > 
SQL Server Management Studio.

2. In the Connect to Server window, enter Localhost and click Connect.
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3. The top node of the tree should say SQL Server 10.0.2531 or greater.  If the last 
number is lower than 2531, install Service Pack 1.

To Install SQL Server 2008 Service Pack 1

1. In Internet Explorer, go to this location:
http://www.microsoft.com/downloads/details.aspx?FamilyID=66ab3dbb-
bf3e-4f46-9559-ccc6a4f9dc19&displaylang=en

2. Download the appropriate file for your operating system and run it.

3. Follow the prompts to install the update.

4. After the installation is complete, restart your computer. 

Consider Installing Cumulative Update 7

Microsoft periodically issues updates to its software to fix issues or bugs. You might 
see performance improvement if you install the Cumulative Update 7 for SQL 
Server 2008 SP1 and configure the SQL Server instance to a parameter switch. 

To do this, download and install Cumulative Update 7 from this location:
http://support.microsoft.com/hotfix/KBHotfix.aspx?kbnum=979065&kbln=en-us

Then do the following:

1. Open SQL Server Configuration Manager (Start > All Programs > Microsoft 
SQL Server 2008 > Configuration Tools > SQL Server Configuration 
Manager).

2. Click SQL Server Services. 

3. Right-click SQL Server properties for the instance running Sage Timberline 
Enterprise, and select Properties.

4. Click the Advanced tab.
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5. Next to Startup Parameters, scroll to the end of the entry and add the string 
; -T  4136 to the end, as shown.

6. Click OK, and then close SQL Server Configuration Manager.

Configure SQL Server to use TCP/IP
Use this procedure to enable TCP/IP if it is not already enabled.

1. Select Start > All Programs > Microsoft SQL Server 2008 > Configuration 
Tools > SQL Server Configuration Manager.
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2. Expand the SQL Server Network Configuration node, and select Protocols 
for instance name.

3. Ensure that TCP/IP is Enabled. If it is not enabled, right-click on TCP/IP and 
change the status to Enabled.

4. If you enabled TCP/IP, restart the service. To do this, select SQL Server 
Services, and for each of the services listed, right-click and select Restart.

5. Verify that the SQL Server Browser service is running.  If it is not running, 
right-click it and select Start.

Configure the SQL Server Default Database Location
Once you have installed SQL Server, you must configure the default database 
location for the instance that will run Sage Timberline Enterprise.

1. Select Start > All Programs > Microsoft SQL Server > SQL Server 
Management Studio and connect to the server.
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2. Right-click the top-level node where your SQL Server instance appears, and 
then select Properties. 

3. In the Server Properties window, select Database Settings.

4. Under Database default locations, select the default data and log folders that 
you set up in the section “Default Data and Log Folder.” 

WARNING:  Do not leave these locations set to the default entries unless you have verified 
that those folders are present and the necessary access has been set up.)

5. Click OK to save your changes.
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Configure SQL Server Memory Usage (Optional)
By default, SQL Server uses all available memory. If you need to limit the amount 
of memory available to SQL Server, while still in the Server Properties window, 
click the Memory page and select the maximum server memory (in megabytes) that 
you want to allow.
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Install and Configure IIS
Internet Information Services (IIS) are Internet-based services for servers. These 
services must be installed and configured on the server that will hold the 
Sage Timberline Enterprise server installation. If you plan to install 
Sage Timberline Enterprise on a different server than Microsoft SQL Server, install 
IIS on the server with Sage Timberline Enterprise.

IIS must be set up to be compatible with IIS 6.0. 

Depending upon your system configuration, the steps to set up IIS vary. Follow the 
steps in this guide careful to ensure that your server is set up correctly.

Install IIS 7.0 on Windows Server 2008 or 2008 R2—page 43.

Install IIS 6.0 on Windows Server 2003 or 2003 R2—page 44.

IIS and ASP.NET are features of Microsoft products. For more information, see 
www.iis.net or www.microsoft.com.

Log On as Administrator
In order to install IIS, log on to the computer that will hold the server installation of 
Sage Timberline Enterprise with the built-in Administrator account, or use the  "run 
as" command at the command prompt. Members of the local administrators group 
do not have the necessary administrative privileges to perform these steps.

Install IIS 7.0 on Windows Server 2008 or 2008 R2

Install IIS by Adding the Web Server (IIS) Role

1. Select Start > Administrative Tools.

2. Do one of the following:

If you are logged in as the administrator, select Server Manager.

If you are not logged in as administrator, right-click on Server Manager 
and select Run as administrator. Enter your administrator name and 
password, and then click Yes.

3. Right-click Roles and select Add Roles. 

4. In the Roles wizard, click Next to proceed to the list of server roles that can be 
added.

5. Select Web Server (IIS) and Application Server.

6. Click Install.
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Add the Role Service

1. Select Start > Administrative Tools.

2. Select Server Manager. (If you are not logged in as administrator, right-click 
Server Manager and select Run as administrator.)

3. Expand the Roles node on the tree, and select Web Server (IIS).

4. Right-click Web Server (IIS) and select Add Role Services. Select the 
following:

Application Development: ASP.NET, ASP

Security: Windows Authentication

Management Tools: IIS 6 Management Compatibility

5. Click Next. 

6. Click Install.

Reset IIS

1. Select Start > All Programs > Accessories.

2. Right-click on Command Prompt and select Run as administrator.

3. When asked if you want to allow the program to make changes, click Yes.

4. Type IISRESET and then press ENTER.

5. Close the command prompt window.

Install IIS 6.0 on Windows Server 2003 or 2003 R2

Install IIS and ASP.NET

1. Select Start > Control Panel > Add or Remove Programs.

2. Click Add/Remove Windows Components. 

3. Select Application Server.

4. Click Details. 

5. Select ASP.NET. Notice that Enable network COM+ access and Internet 
Information Services (IIS) are selected automatically.

6. Click OK. 

7. Click Next.

8. Click Finish.
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Confirm the status of ASP.NET

1. Select Start > Administrative Tools > Internet Information Services (IIS) 
Manager.

2. Expand the folder for your server and then select Web Service Extensions.

3. Under Web Service Extension, verify that ASP.NET v2.0 05727 has a status of 
Allowed.

4. Close the Internet Information Services (IIS) Manager window.

Register ASP.NET and reset IIS

1. Select Start > Run.

2. Type CMD in the Open box, and then click OK to open the command prompt.

3. Type C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\aspnet_regiis 
-i and then press ENTER. Confirm that ASP.NET is registered properly.

4. At the command prompt, type IISRESET and then press ENTER.

5. Close the command prompt window.
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Install Sage Timberline Enterprise on the 
Server

1. Insert your Sage Timberline Enterprise installation DVD at the server. In the 
Setup and Installation window, click Perform system verification.

2. In the Sage System Verifier window, click Scan System.

3. If any issues are found, you must address them before you can continue with the 
installation. The Details section of the window provides information about 
issue resolution. If no issues are found, click Close.

4. In the Setup and Installation window, under Install, click Server components 
and tools. 
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5. You may be asked to install prerequisites. Click Install to install each 
prerequisite. 

6. In the Sage Timberline Enterprise Server Setup window, click Next. 

7. In the End-User License Agreement window, select I accept the terms in the 
License Agreement, and then click Next. 
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8. In the Destination Folder window, select the installation destination to which 
you want to install the software, and then click Next. 

9. In the Ready to install Sage Timberline Enterprise Server window, click 
Install. 

10. When the setup wizard completes the installation, click Finish. 
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Install Payroll on the Server
Payroll is an optional module that you can use with Sage Timberline Enterprise. 
Payroll uses a Pervasive.SQL database, rather than a SQL Server database.

1. At the server, insert your Sage Timberline Enterprise installation DVD. 

NOTE:  Payroll cannot be installed from a network location.

2. In the Setup and Installation window, under Install, select Additional 
Installs.

3. Open the STE Payroll folder.
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4. Open the AccountingServer folder, and then double-click Install.exe.

5. Click Install Enterprise Payroll Server software. 

6. Read and perform the steps listed in the Preparation window. Select I have 
read and completed these steps, and then click Next. 
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7. In the Prerequisites window, you can view the status of the additional software 
that is required to run Payroll. Click Next to continue. 

8. In the License Agreement window, click Yes to agree to the terms of the 
software.
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9. In the Ready to Install the Program window, click Install. 

10. When the installation is complete, click Finish.

11. A message tells you that you must restart your computer.  Click Yes.
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12. After the computer restarts, the Sage Configuration Manager starts 
automatically to complete security upgrades.  Wait for the process to finish, and 
then click OK.
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Install Sage Timberline Estimating

You can integrate Sage Timberline Enterprise with Estimating and then send your 
estimates to Job Management, where you monitor progress against each job.

You can install the Sage Timberline Estimating application on the server, or you can 
install only the databases. If you do not plan to use the application directly at the 
server, install only the databases. To install only the databases, follow this 
procedure through step 4.

1. Insert the Estimating DVD. In the setup window, click Install Sage Timberline 
Office Software.

2. In the Before You Install window, select the I have read and completed these 
steps check box, and then click Continue the Install.
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3. In the Requirements Checklist window, click Start. Once the prerequisites are 
installed, the installation is prepared.  

NOTE:  If you see a system verification error indicating that your target platform failed 
verification, please contact Sage for assistance.

4. If you are installing only the databases at this time, click Cancel—you are 
finished installing the databases. Otherwise, click Next.

5. In the License Agreement window, click Yes.
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6. In the Choose Destination Location window, click Next.

7. In the Select Features window, select the Estimating applications you want to 
install.

8. Click Next, and enter your activation codes from the list that you received with 
the software. (If you plan to use License Manager, some applications have 
License Manager codes. Type LM in in this window for those applications.  
Instructions for installing License Manager start on page 59.)
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9. Click Next.

10. Click Next. The product installation takes a few moments.

11. When the installation is finished, restart your computer and wait for the 
configuration tasks to finish.

12. Select Start > Programs > Sage > Sage System Verifier, and then click 
Scan System.

13. Once the scan is finished, close the window.

14. Before you can open Estimating and configure it to work with Job Management, 
you’ll need to configure your licensing.

If you will use License Manager to manage your Estimating licenses, 
continue with “Install License Manager” on the next page. 

If you will not use License Manager, attach the Sentinel protection device 
to the computer’s parallel or USB port before you open Estimating.  (If you 
are using a parallel port, first remove any devices connected to the parallel 
port. Attach the protection device to the parallel port and then reconnect 
your other devices to the back of the protection device.
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Install License Manager
License Manager lets you set up a greater number of Estimating workstations than 
you have licenses, and then manages concurrent uses for you. License Manager 
consists of the following components:

Sentinel protection device

Sentinel System Driver

License Manager application

Estimating Licenses

Attach the Protection Device to the License Server

The License Manager protection device is a piece of hardware that you connect to 
the parallel port or USB port on the license server.  This device authorizes License 
Manager to distribute licenses to clients.

1. If you are using a protection device on a parallel port, remove any devices 
connected to the parallel port.

2. Attach the protection device to the parallel port to the available USB port.  
Reconnect any parallel devices to the back of the portection device.

Install the Sentinel Driver on the License Server

The Sentinel driver provides communication between the license server and a 
license-managed application through the protection device. You must install the 
Sentinel driver on the license server (it is installed automatically if you install 
Estimating). To install the driver:

1. At the computer designated as the License Manager server, insert the DVD and 
browse to the folder  X:\Prerequisites\Safenet (where X: represents your 
DVD-ROM drive).

2. Double-click Sentinel Protection Installer 7.6.1.exe and complete the 
installation.

3. Restart the computer when the installation finishes.

Install License Manager on the License Server

NOTE:  When you first install License Manager on the server, the server and all 
workstations that will use Estimating must be on the same subnet. After you install License 
Manager you can move workstations to a different subnet if you need to. For more 
information, check the Sentinel License Manager help for instructions.

1. At the computer designated as the License Manager server, insert the DVD and 
log on as the local administrator.
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2. Browse to the folder X:\AdditionalInstalls\LicenseManager\Server\Setup 
(where X: represents your DVD-ROM drive).

3. Double-click Setup.exe and complete the installation wizard.

4. Restart the computer when the installation finishes.

5. Open Estimating on a workstation to verify that License Manager is configured 
properly.

Install Estimating Licenses on the License Server

Install your license codes on the license server.

1. Verify that the License Manager service is running>  Select  Start > Control 
Panel > Administrative Tools > Services and then select Sentinel RMS 
License Manager. The status of the service should be Started.

2. Start the WLMAdmin utility as follows:

If License Manager Tools have been installed, select Start > Programs > 
Timberline Office > Estimating > License Manager Utilities > 
WLMadmin.

If License Manager Tools have not been installed, insert the Estimating 
DVD and double-click 
X:\additionalinstalls\LicenseManager\Admin.net\Win32\ 
WLMAdmin.exe (where X:\ represents your DVD-ROM drive).

3. Click to expand Subnet Servers.

4. If you are installing license codes from a file:

a. Right-click the License Manager server, and select Add Feature > From a 
File > To Server and its File.

b. Browse to the License Manager code file, select it, and click OK.

5. If you are installing license codes from a string:

a. Right-click the License Manager server, and select Add Feature > From a 
String.

b. Select the Add feature to server’s file check box.

c. Type a code from the packing slip that you received with your software, and 
then click Add.

d. Continue adding codes until all codes have been entered.

Work With Commuter Licenses

Use the utility called WCommute to check licenses in or out. 
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If License Manager Tools have been installed, select Start > Programs > Sage 
Software > Sage Timberline Office > Estimating > License Manager 
Utilities > Commuter License Manager.

If License Manager Tools have not been installed, insert the Estimating DVD 
and double-click the file 
X:\additionalinstalls\licensemanager\Admin.net\Win32\wcommute.exe (where 
X:\ represents your DVD-ROM drive).

NOTE:  See the License Manager Help topic called “Using WCommute” for further 
instructions.

Configure Estimating for Use with Enterprise Job 
Management

Once you have installed Estimating, configure the interface with 
Sage Timberline Enterprise Job Management.

1. Open Estimating Tools (Start > Programs > Sage > Sage Timberline Office 
> Estimating > Estimating Tools).

2. Select Setup > Change Job Cost Information.

3. Select the Estimating database that you want to use with Sage Timberline 
Enterprise.

4. In the Job Cost Interface Type field, select Sage Timberline Enterprise.

5. Click OK. The database is configured.
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Server Configuration

This section shows you how to configure your licenses, databases, and users in 
Sage System Administration once you have installed all of the server components 
described in the last section. Complete the tasks in this section in order for best 
results:

In Sage System Administration, run the Configuration Wizard (page 64).

Activate your Sage Timberline Enterprise licenses (page 71).

Set up the sample database (page 73).

Develop and implement a Sage Timberline Enterprise security plan (page 81).
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Configure Sage System Administration

After you install Sage Timberline Enterprise, you must configure the Sage System 
Administration settings by running the Configuration Wizard. 

Important Points about the Configuration Wizard
The wizard starts automatically the first time you start Sage System Administration. 
To run the Configuration Wizard successfully:

You must first be set up as a system administrator in SQL Server. 

You must run the Configuration Wizard at the server on which you installed 
Sage Timberline Enterprise and the Internet Information Services. (Although 
you can open System Administration from a workstation, you must complete 
this procedure at the server.)

Run the Configuration Wizard
1. Open Sage System Administration by selecting Start > All Programs > Sage 

> Sage System Administration.)
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2. When the window opens, click the Sage Timberline Enterprise SA node to 
bring up the Log on window.

3. In the Log on window, type the name of the Web server (for example, 
localhost), and then click OK. 

4. In the Select Mode window, choose the mode in which you want to configure 
your Sage System Administration software. 

If you installed SQL Server using the default instance, you can select 
Simple Mode to set up Sage System Administration with the most common 
configuration options. 
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If you installed SQL Server using a named instance, you must select 
Advanced Mode. This option gives you more control over the 
configuration process.

5. Click Next to continue. A warning message appears regarding SQL Server 
updates.

NOTE:  We recommend that you install SQL Server 2008 SP1 Cumulative Update 7. You 
can download this update from Microsoft’s website.

6. Click OK.

If you selected Simple Mode, click Configure and wait for the wizard to 
finish.
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If  you selected Advanced Mode, you see the Database Log On window. 
Continue with this procedure.

7. In the Server name box, select the SQL Server instance that you set up when 
you installed SQL Server for Sage Timberline Enterprise. Click Next.

8. The next window differs based on whether you have had an earlier installation 
of Sage Timberline Enterprise or run the configuration wizard before.
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If you have had an earlier installation of Sage Timberline Enterprise, or you 
have run the configuration wizard on this computer before, select the 
configuration options for the SAAConfiguration database.

Select Rename the existing database or Delete the existing database and 
click Next.

If you have never run the configuration wizard on this computer before, you 
see the Web Services Check box.

9. In the Web Service Check window, click Next.

10. The next window again differs based on previous configuration.
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If you have have run the configuration wizard on this computer before, 
select the configuation options for existing Web Service.

Select Rename the existing web service or Delete the existing web 
service and click Next.

If you have never run the configuration wizard on this computer before, you 
see the Configure window.

11. In the Configure window, click Configure. 

show both options?
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12. When the process is finished, the web service connection is established and you 
are logged on to the System Administration server again.
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Activate Your Sage Timberline Enterprise 
Licenses

Once you install Sage Timberline Enterprise, you must activate your licenses in 
order to use the software. You must be connected to the Internet to activate licenses.

Each license has a specific number of associated uses, which are distributed 
amongst workstations. This section covers the following options for activating 
licenses and distributing uses:

Activate licenses on a single server (most common scenario). 

Activate licenses on multiple servers.

Understand the Default License Activation Process
When your server first connects to Sage to activate licenses, all of your available 
uses are assigned to that server. (If you use the optional Payroll module, your 
Payroll licenses are activated at the same time.) If you take no further action, uses 
remain allocated to that server and other servers will have none available. If you use 
only one server, this is the appropriate configuration. 

However, if you use multiple servers, you must use the multi-server licensing 
procedure described below to ensure that each of your servers can access 
Sage Timberline Enterprise.

If you mistakenly allocate all uses to a single server and you need to correct the 
issue, simply open License Administration at the server that has all the licenses 
and distribute the licenses as needed according to the instructions for multi-server 
licenses.

Activate Licenses on a Single Server
In a standard client/server environment, you install Sage Timberline Enterprise on 
a single server and then activate the server’s license. The uses allocated to that 
license are assigned to each workstation in succession as they connect. 

1. In System Administration, select License Administration.

2. Click Edit Registration Information. Type your client ID exactly as provided 
to you by Sage.

3. In the Registration name box, type the name exactly as provided to you by 
Sage. The license activation occurs automatically when you enter the 
information correctly. If you use the optional Payroll module, your Payroll 
license is activated as well.
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NOTE:  If the client ID and registration name do not exactly match those you received from 
Sage, the license activation does not succeed.

How Uses are Distributed in the Single-Server Scenario

If five uses are assigned to your license, the first five workstations to connect to the 
server are allowed to connect.  The sixth workstation that requests simultaneous 
access is denied.

Activate Licenses on Multiple Servers
If you have more than one server with the Sage Timberline Enterprise software 
installed (for example, if you have multiple corporate offices, each with a local 
server to which users will connect), you can distribute the available uses amongst 
these servers. Each server assigns only the uses allocated to it. 

1. In System Administration, select License Administration.

2. In the Sage client ID box, type your client ID exactly as provided to you by 
Sage.

3. In the Registration name box, type the name exactly as provided to you by 
Sage. The license activation occurs automatically when you enter the 
information correctly.  If you use the optional Payroll module, your Payroll 
license is activated as well.

NOTE:  If the client ID and registration name do not exactly match those you received from 
Sage, the license activation does not succeed.

4. Click Multi-server licensing. 

5. Select Manually specify license allocations for this server.

6. Enter the number of uses for this server for each module in the Uses for server 
name column.

7. Click OK to allocate the licenses.

How Uses are Distributed in the Multiple-Server Scenario

If ten uses are assigned to your license, you might allocate five to each of two 
servers (Server1 and Server2). The first five workstations to connect to Server1 
are allowed to connect.  The sixth workstation to try connect to Server1 is denied. 
However, it can connect to Server2 if uses remain available on that server.
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Set Up the Sample Database
Before you can start using Sage Timberline Enterprise, you need to set up your 
databases, users, and roles. These tasks require you to develop your security plan 
for the software—which you may not have done yet. 

This section gets you started by showing you how to set up a system administrator 
for Sage Timberline Enterprise, attach the sample database, and give access to a 
user. When you are ready to develop a complete security plan for your organization, 
the section “Develop and Implement a Security Plan” starting on page 81 covers all 
of the details and decisions you’ll want to consider in your plan.

NOTE:  You can complete the following procedures at the server or at a workstation (if Sage 
Timberline Enterprise is already installed on the workstation). You must be logged on to 
Windows as a Sage Timberline Enterprise administrator in order to set up the sample 
database, users, and roles.

Set Up a System Administrator
Your first task is to set up a system administrator for Sage Timberline Enterprise. 
This individual manages the databases, users, and roles for the entire 
Sage Timberline Enterprise system, and also has administrative permissions for the 
SQL Server instance on which Sage Timberline Enterprise is installed. 

To set up the system administrator, follow these steps:

1. Start Sage System Administration if it is not already open (Start > All 
Programs > Sage > Sage System Administration). 

2. Expand the tree on the left and click System Administrators. 
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3. Click Add new administrator.

4. Select the Domain and Logon name for the administrator. Click the Refresh 
button to refresh the list.

5. Leave the System Administration window open so you can return to it.

Attach the Sample Database
The sample database is provided with the software to help you learn its functions 
and plan your implementation. It is the same database that is used in 
Sage Timberline Enterprise training classes.

To attach an existing database, you first place the database file in your default data 
folder and attach it in SQL Server. Then you add the database to Sage System 
Administration so that you can associate users with it.

Move the training data files to the default data folder

1. In Windows Explorer, browse to the location of the training data .mdf file.

2. Move the file to your default data folder (the one you specified when installing 
SQL Server).

Attach the database in SQL Server Management Studio

1. Select Start > All Programs > Microsoft SQL Server 2008 > SQL Server 
Management Studio.

2. Verify that the correct server and instance are selected, and then click Connect 
to log on.
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3. Right-click the Databases folder and select Attach.

4. Click Add, and then browse to your default data folder.

5. Click the .mdf file for the database you want to attach, and then click OK.

6. In the lower grid, if the Message column shows Not Found for either the data 
or log folder, click the browse button and browse to your default data and log 
folder. If you do not have a log (.ldf) file, click the row for the log file and then 
click Remove.

7. Click OK.  When the window closes you should see the new database in the list.

8. Close SQL Server Management Studio.
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Add the Database to Sage System Administration

1. Open Sage System Administration and log on if it is not already open.

2. Click Database Administration.

3. Click Create New Database.

4. Enter a display name for the database, and then enter the path to the attachments 
and spool folders that you created and shared earlier (page 17).

NOTE:  When you enter the path name, use the format \\ServerName\FolderName rather 
than specifying a drive letter path. The directory must be shared in the folder’s Properties.

5. Next to server, enter the server and the SQL Server instance name in the format 
ServerName\InstanceName.

6. Next to Database Name, click the refresh button and select the database from 
the list.

7. If you have installed or upgraded the optional Payroll module, complete these 
steps to to link to the correct Payroll database. Otherwise, click OK.

a. Click the Payroll settings tab.

b. Select the Enable Payroll check box.
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c. From the Database list, select the Payroll database you want to associate 
with this company database. 

d. If you are using security in Payroll, enter the User name and Password 
needed to log into the secure database. 

8. Click OK. Note that before you can use the database, you must add at least one 
user and one role.

Add a User and a Role to the Database
You must add at least one user and one role to the database in order to begin using 
Sage Timberline Enterprise. You add users using their Windows domain logon 
name.

Add a User

1. In System Administration, click Database Administration.

2. Under Databases, select the database.
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3. On the Users tab, click Add new user.

4. Your domain should already be selected. Type the user logon name or click the 
Refresh button to select from a list of domain users, and then click OK.

NOTE:  For more information about adding or maintaining users, see the System 
Administration Help topics called “Users tab” and “Maintaining users.”

Add a Role

Roles let you assign user permissions according to the tasks they perform.

1. In Database Administration, click the Roles tab.

2. Click Add new role.
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3. In the Role name box, type Training so that you can use this role for training 
purposes. 

4. Click OK.

5. In the Authorize Features For Role window, select the Features check box, 
so that all features will be selected for the Training role. 

6. Click OK.

7. In the Members of box, select the user that you added to this database.  

NOTE:  For more information about roles and features, see the System Administration Help 
topics called “Roles tab” and “Authorize Features for Role window.”
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Develop and Implement a Security Plan
If you have set up the sample database to work with Sage Timberline Enterprise, 
you already have at lease one user, role, and system administrator set up in System 
Administration. To develop a complete security plan for your organization, you’ll 
need to create lists of employees and the tasks they perform regularly, and then 
organize these lists into roles and features sets.

This section walks you through each of the security planning steps and 
considerations, with examples from the sample database, and then shows you how 
to implement your plan in System Administration.

Understand Security in Sage Timberline Enterprise
Sage Timberline Enterprise security can be as simple or as robust as you need it to 
be. You define the level of access that each of your employees has to the modules 
and workflow tasks, as well as which databases they can access. If you have several 
employees who perform similar functions, you can assign each of them to the same 
role, facilitating your setup work.

NOTE:  You can complete the procedures in this section at the server or at a workstation 
(if Sage Timberline Enterprise is already installed on the workstation). You must be logged 
on to Windows as a SQL Server administrator in order to complete the steps.

Security in Sage Timberline Enterprise is composed of the following elements, 
each of which are managed in System Administration.

System administrators. The system administrator manages the databases, users, 
roles, and features for the entire Sage Timberline Enterprise system. This 
individual also has administrative permissions for the SQL Server instance on 
which Sage Timberline Enterprise is installed. Consider appointing more than 
one individual to this role so that you have adequate coverage. 

Databases. Databases hold your Sage Timberline Enterprise data. All users that 
you add in System Administration are associated with a particular database. 

Users. Sage Timberline Enterprise operators must be added to the database to 
which they will have access. You use Windows domain logon names to add 
users to the system. 

Roles. A role defines a set of permissions accessible to a user associated with 
that role. In order to access features in the software, users must be assigned to 
at least one role.

Features. Tasks that you can perform in the software, such as entering invoices 
or entering transactions into General Ledger, are features that you can assign to 
roles.
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Understand Security in Payroll
The optional Payroll module has its own security setup. 

To learn about Payroll security, open Payroll and select Help > Documents. 
Open SecurityGuide.pdf and read the document before planning your Payroll 
security model.

To enable Payroll security, select Tools > Security Setup and then click 
Security Settings. Press F1 at any time for help with the active window.

Establish Your System Administrators
The system administrator for Sage Timberline Enterprise manages the databases, 
users, and roles for the entire Sage Timberline Enterprise system, and also has 
administrative permissions for the SQL Server instance on which 
Sage Timberline Enterprise is installed. You probably added at least one system 
administrator when you installed the software. Considering assigning more than 
one individual to this role so that you have adequate coverage.

To set up the system administrator, follow these steps:

1. Start Sage System Administration if it is not already open (Start > All 
Programs > Sage > Sage System Administration). 

2. Expand the tree on the left and click System Administrators. 

3. Click Add new administrator.
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4. Select the Domain and Logon name for the administrator. Click the Refresh 
button to refresh the list.

5. Leave the System Administration window open so you can return to it.
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Create a Database
Except for system administrators, all users that you add in the System 
Administration module are associated with a particular database. Before you can 
add the users, you must create the database. 

Note that the configuration settings for your database require careful consideration. 
We recommend that you work with a certified consultant and reference the setup 
documentation we provide to facilitate this process. However, if you are ready to 
start setting up security, you can create the database now and plan to refine the 
configuration settings later. Alternately, you can apply your security plan to the 
sample database for practice. 

1. In System Administration, click Database Administration.

2. Click Create New Database.

3. On the Database Settings tab, enter a name for the database and the location of 
the Attachments and Spool folders. (For more information about these folders, 
see page 17.)

4. Next to Server, enter the name of the server.

5. Next to Database name, enter the name to use for your database files.

6. Click OK, and answer Yes to the confirmation message.
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7. Select the starting month for your fiscal year, and then click OK. After a 
moment, the database appears in the list.

Establish the List of Users
Sage Timberline Enterprise is integrated with Windows security, so you’ll use 
Windows logon names to set up users in System Administration.  Your users must 
already be set up in the domain’s Active Directory before you can add them to 
System Administration.

NOTE:  Users with access to a database can access all records in that database through 
reporting and third party data access tools, including ODBC, SQL queries, Crystal Reports, 
and others.

To begin planning, create a list of users. Your list should include every employee in 
your organization who will have access to Sage Timberline Enterprise. 

Add Users to the Database
1. In System Administration, click Database Administration.
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2. Under Databases, select the database. (Whenever you add a user, you associate 
the user with the database you have selected.)

3. On the Users tab, click Add new user.

4. Your domain should already be selected. Type the user logon name or click the 
Refresh button to select from a list of domain users, and then click OK.

5. Notice that the Users tab shows you the list of users that you have added so far.  
When you click a user, you see the roles to which that user is assigned, as well 
as the corresponding features.

NOTE:  For more information about adding or maintaining users, see the System 
Administration Help topics called “Users tab” and “Maintaining users.”
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Establish a List of Roles
Roles are used to set permissions more efficiently, by grouping sets of features. For 
example, you might have an Accounts Payable role, a Dispatcher role, and a Service 
Agreements role, each with access to different tasks in the software.

Establish a list of roles to which each user will be assigned. You will probably find 
that you need to refine the features associated with each role, or even add new roles, 
as you learn about how your workflows are best accommodated. 

Add Roles and Authorize Features
Roles let you assign user permissions according to the tasks they perform. You 
specify the features (tasks you can perform in the software) that are available to 
users associated with that role. For example, a user associated with a role called 
Accounts Payable might be able to set up vendors and enter invoices. 

1. In Database Administration, click the Roles tab.

2. Click Add new role.
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3.  In the Role name box, type a name for the role.

4. Click OK.

5. In the Authorize Features For Role window, select the check boxes for the 
features that you want to assign to this role.

6. Click OK.

7. In the Members of box, select the users that you want to add to the role. 
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8. Click the Features tab, and notice that you can manage users and roles by 
feature from this tab.

NOTE:  For more information about roles and features, see the System Administration Help 
topics called “Roles tab” and “Authorize Features for Role window.”
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Workstation Installation

Once you have installed the server components and configured your software, you 
are ready to install Sage Timberline Enterprise on your workstations. This section 
shows you how to:

Install Sage Timberline Enterprise on a workstation (page 92).

Install Payroll on a workstation (page 96)

Test your installations (page 101).
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Install Sage Timberline Enterprise on 
Workstations

Insert your Sage Timberline Enterprise installation DVD at the workstation. 

1. In the Setup and Installation window, click Perform system verification.

2. In the Sage System Verifier window, click Scan System.

3. If any issues are found, you must address them before you can continue with the 
installation. The Details section of the window provides information about 
issue resolution. If no issues are found, click Close.
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4. In the Setup and Installation window, under Install, click Workstation 
components and tools.

5. You may be asked to install missing prerequisites. Click Accept to continue. 

6. If you are asked whether you want to install the Sage Timberline Enterprise 
MSExcel AddIn, click Install. 
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7. In the Sage Timberline Enterprise Client Setup window, select Next. 

8. In the End-User License Agreement window, select I accept the terms in the 
License Agreement, and then click Next.

9. In the Destination Folder window, select the installation destination to which 
you want to install the software, and then click Next. 
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10. In the Ready to Install Sage Timberline Client window, click Install.

11. When the setup wizard completes the installation, click Finish.
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Install Sage Timberline Enterprise Payroll on 
Workstations

Payroll is an optional module you can use with Sage Timberline Enterprise. You 
must install it on the server before you can install it on the workstation.  If you have 
installed on the server, follow these instructions to install Payroll on the 
workstation.

Insert your Sage Timberline Enterprise installation DVD. You must do this at the 
server. Payroll cannot be installed from a network location.

1. At the workstation, browse to the shared Timberline Office folder drive on the 
server. (The Payroll server installation automatically shares this folder.)

2. In the shared folder, browse to 9.5\Accounting\WinInst.

3. Double-click Install.exe.

4. Click Install Enterprise Payroll Client software.
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5. If you see a message that your system’s Windows Installer service must be 
upgraded, click Yes and complete that installation before continuing. (The 
installation will require you to restart the computer.)

6. Read and perform the steps listed in the Preparation window. Select I have 
read and completed these steps, and then click Next. 

7. In the Prerequisites window, you can view the status of the additional software 
that is required to run Payroll. Click Next to continue. 
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8. In the License Agreement window, click Yes to agree to the terms of the 
software.

9. In the Product Options window, select the first option, and then click Install.
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10. When the installation is complete, in the End window, click Finish.

11. A message indicates that you must restart your computer.  Click Yes and allow 
the computer to restart before continuing.

Install Estimating on Workstations
If you use Estimating, install it by following the procedure on page 55.  The 
installation for the server and workstation are the same for Estimating.
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Test Your Sage Timberline Enterprise 
Installations

Follow these instructions at a workstation to make sure that your installation was 
successful.

1. Select Start > All Programs > Sage > Sage Timberline Enterprise.

2. In the the Logon screen, enter your Windows password.

3. Select the Server and Database to which you want to connect.

4. Click OK. Sage Timberline Enterprise should open successfully.
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System Maintenance

Once you have installed Sage Timberline Enterprise and begun using it for daily 
business, you will have an ongoing need to complete certain system administration 
and maintenance tasks. Some of these tasks, such as backing up your data, should 
happen at regularly scheduled times. Others will happen as needed, based on events 
such as upgrades, employee turnover, and hardware replacement. 

The remainder of this guide provides information about system maintenance tasks.

Task Information

❑ Back up your databases on a regular basis. page 105

❑ Move the Sage Timberline Enterprise installation to a different server. page 111

❑ Download and install software updates. page 117
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Back Up Your Data
Backing up your data regularly is a critical component of disaster-recovery 
planning. You can lose data because of power outages, hardware failures, natural 
disasters, malicious acts, and many other causes too numerous to list. How much 
business information can you afford to lose? One day’s worth? One week’s worth? 
Your backup plan should take this into account and mitigate your risk of losing 
more than your specified tolerance.

Work with your certified consultant and information technology professionals to 
implement a backup schedule that protects you from catastrophic loss. Consider 
each of these factors:

Types of backups

Frequency of backups

Storage location for backup media

Testing and recovery

For information about which files to include in a backup of Sage Timberline 
Enterprise, see “Locations to Include in a Backup” on page 107.

Types of Backups
Your backups can be a complete copy of all data or they can capture only the 
changes since the last backup. Your backup plan should strike a balance between 
the time needed to run each type of backup and the security of your data.

A full backup is a complete backup of all data. This backup type is the most 
time-intensive.

A differential backup is a cumulative backup of all changes made since the last 
full backup. This type of backup is usually faster than a full backup. However, 
if so much time has elapsed since the last full backup that most files need to be 
included, the time savings is minimal. To restore from a differential backup, you 
must first restore the last full backup, and then restore the differential backup.

An incremental backup is a backup of only the files that have changed since 
the last full or differential backup. This is the fastest type of backup because it 
copies only a fraction of all files. However, to restore from an incremental 
backup you must first restore the last full backup, and then restore the last 
differential backup, and finally restore each incremental backup since the last 
differntial backup. Each of these must be completed in the correct order 
(restoring oldest backups first and newest last).
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Frequency of Backups
A combination of daily, weekly, and monthly backup cycles can help you balance 
the need for frequent backups of ongoing daily transactions with the need for 
reliable archives of large amounts of data. 

At the minimum, you should have an incremental backup daily. You might perform 
full backups weekly, and incremental or differential backups daily for a complete 
picture that is never more than one week old.

In addition to regularly scheduled backups, perform backups immediately 
following significant events such as month-end or year-end processing, software 
upgrades, or server migrations.

Storage Locations for Backup Media
Store backups on different physical media than their original location.  If you lose 
data because of disk failure, a backup stored on the same disk will not be any more 
accessible than the original data.

Periodically, media containing a full backup should be transferred to a separate, 
secure physical location such as a safety deposit box or a secure data storage and 
management company. Media stored on-site can be restored in the case of hardware 
failure—but in the case of a natural disaster, you might have to retrieve off-site 
media. Many companies store periodic full backups in a different geographic region 
to protect from regional disasters. 

Testing and Recovery
Every viable backup plan must include restoring backups to a test environment on 
a regular basis. Until you have tested a particular backup set, you don’t know for 
certain that the files were not corrupted, lost, skipped, or otherwise rendered 
unusable. If any of these conditions exist, you might as well not have a backup at 
all. An inaccessible or unusable backup does not protect your business the way it’s 
supposed to.

As part of your regular backup schedule, restore backups to a testing environment 
and run data checks such as inquiries or reports. If your restored data does not meet 
your standards, you need to find the cause of the problem, fix it, and run another 
backup before your disaster-recovery plan can be considered effective.
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Locations to Include in a Backup

In addition to your database files, several other folder locations contain files that 
you will need in the event that you must restore a system from backup. Note the 
following:

Most of your Sage Timberline Enterprise data is stored in SQL Server database 
files. These are the .mdf and .ldf files in the default SQL data location. You can 
use SQL Server’s backup tools to back up this portion of the data.

The SAAConfiguration database should be backed up with your other Sage 
Timberline Enterprise data. This is a SQL Server database that the system uses 
to store changes to system administrators or company database configurations. 
Use SQL Server’s backup tools to back up this database along with the others.

Each Sage Timberline Enterprise database has associated Attachment and 
Spool folders. These folders are not included in backups created by SQL 
Server’s backup tools. Plan to archive them separately at the same time you 
back up your SQL database files. 

If you have the optional Payroll module, the payroll data is stored in a Pervasive 
database. Back up your Pervasive and SQL Server databases at the same time 
to keep them synchronized.

Back up SQL Server Databases
The steps below outline a procedure for backing up your SQL Server databases.  
Modify these steps as needed based on your company’s internal requirements and 
system configuration.

1. When the scheduled backup time arrives, ensure that all users are disconnected 
from Sage Timberline Enterprise. 

a. In Sage System Administration, go to License Administration and click 
the Active Users tab to see the list of active users. Ask each of the users 
listed on this tab to log out of the software.

b. Click Restrict Logon. (This prevents new connections to any 
Sage Timberline Enterprise database, but it does not close existing 
connections.)

2. Start SQL Server Management Studio (Start > Programs > Microsoft 
SQL Server > SQL Server Management Studio) and connect to the server 
that hosts the database you want to back up. 

3. Expand Databases under the SQL Server instance.
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4. Right-click the database and select Tasks > Back Up.

5. Select the options for the backup. For information on the options, click Help.

6. Click OK to begin the back up process. 

7. After the backup is complete, repeat this process for all databases that you need 
to back up, including the SAAConfiguration database.

8. In System Administration, click Allow logon when you are finished to allow 
users back in to the software.

Back up Pervasive Databases
Backup up Pervasive databases using File Tools, a utility included with Payroll. 

1. In Payroll, select Tools > File Tools. 

2. Select Backup, and then click Next.

3. Click Add Folder and select your company data folder.

4. Click OK, and then click Next.

5. Next to Destination, click Browse to select the location to save the backup file. 
In the Archive Name box, enter a name for the file.

6. Click Next to start the process, and continue clicking Next to complete the 
wizard.

7. When the process is complete, click Finish. 
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Back up Other Important Folders
Along with the database files, back up these other folders using your preferred 
backup application.  (These folders are not included in SQL Server or Pervasive 
backups).

Attachment and Spool folders. To locate these folders for each database, in 
System Administration, select the database and click Database Properties.

The folder Documents and Settings\All Users\Application Data\Sage. This 
folder contains additional Sage Timberline Enterprise information.
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Move Sage Timberline Enterprise to a New 
Server

You might decide to move your Sage Timberline Enterprise installation to a 
different server in order to take advantage of newer hardware or system resources. 
With planning, you can complete this transition smoothly. Review the tasks in this 
checklist before you begin a server migration.

Prepare the New Server for the Migration
Complete the following preparation tasks on the new server, referring to the pages 
listed for more information.

Review the system specifications for Sage Timberline Enterprise and verify that 
your new server meets the minimum requirements (page 7).

Verify that your new server is part of a Windows domain, and add it if necessary 
(page 15). If you are moving Sage Timberline Enterprise to a different 
Windows domain, add all users to Active Directory for the new domain.

Configure the new server’s firewall as needed (page 15).

If you are also moving the Microsoft SQL Server 2008 installation: 

Determine the new location for your database, spools, and attachments 
folders (page 17).

Install SQL Server on the new server and configure it to work with Sage 
Timberline Enterprise (page 22). 

Task Information

❑ Prepare the new server for the migration page 111

❑ Back up your data page 105

❑ Schedule the migration page 112

❑ Disconnect all users page 112

❑ Move your databases to the new location page 112

❑ Deactivate your Sage Timberline Enterprise licenses on the old 
server

page 114

❑ Install remaining software on the new server page 115

❑ Configure users on the new database if necessary page 115

❑ Verify that your users and workstations can connect to the new 
server

page 115
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Schedule the Migration
The migration process requires that all users be disconnected from the 
Sage Timberline Enterprise database you are moving. Schedule a time when this 
will be least disruptive to your business, such as an evening or weekend. The time 
required will vary according to the size of your databases and the speed of your 
network.

If your SQL Server instance also contains other databases, you can select a 
migration method that allows the other databases to remain in use during the 
migration. This is true whether the other databases are associated with 
Sage Timberline Enterprise or another application. The available methods are 
outlined below.

If you have more than one database associated with Sage Timberline Enterprise, 
consider whether you will migrate all databases during the same scheduled time 
frame (requiring all users to close Sage Timberline Enterprise), or you will migrate 
databases at different scheduled times to allow some databases to remain active.

Disconnect all Users
When the scheduled migration time arrives, ensure that all users are disconnected 
from Sage Timberline Enterprise.

1. In Sage System Administration, go to License Administration and click the 
Active Users tab to see the list of active users. Ask each of the users listed on 
this tab to log out of the software.

2. Click Restrict Logon. (This prevents new connections to any 
Sage Timberline Enterprise database, but it does not close existing 
connections.)

Move Your Databases to the New Server
If you plan to move your installation of Microsoft SQL Server to a new server (as 
well as the Sage Timberline Enterprise installation), you must move your databases 
to the new database server. Otherwise, you can skip to “Deactivate Licenses on the 
Current Server” on page 114.

Verify that you have a reliable backup of your database, and that all users are logged 
out of the database. Then, use one of the following methods to move the databases. 
(Instructions for each of these start on the next page.)

Back up and restore the databases. Backup files are smaller than the original 
files, so this method may result in less time needed to copy the database to the 
new location. This option also allows all SQL Server databases (including the 
one you are copying) to remain in use during the process. If you have other 
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databases on the server, this is a benefit, but any changes made to the database 
after you create the backup will be lost. 

Detach and move the databases. This method allows all SQL Server databases 
on the server to remain in use, except for the database you are moving. The files 
are not compressed in this option, so moving the data may require more time.

Stop the SQL Server services and copy the databases. This method prevents 
users from accessing any database on the SQL Server instance that hosts 
Sage Timberline Enterprise. If you have other databases that use the same SQL 
Server instance and you need them to remain available, select one of the other 
options.

To Back Up and Restore the Database

1. At your current server, log on to SQL Server Management Studio (Start > 
Programs > Microsoft SQL Server 2008 > SQL Server Management 
Studio).

2. Expand Databases. Right-click the database and select Tasks > Back Up. 
Specify the Backup type as Full, and enter the location to store the backup. 
This process creates a .bak file in the location you specified.

3. At the new server, log on to SQL Server Management Studio (Start > 
Programs > Microsoft SQL Server 2008 > SQL Server Management 
Studio).

4. Right-click Databases and select Restore Database. Select the .bak file from 
step 2.

To Detach and Move the Database

1. At your current server, log on to SQL Server Management Studio (Start > 
Programs > Microsoft SQL Server 2008 > SQL Server Management 
Studio).

2. Expand Databases. Right-click the database and select Tasks > Detach.

3. In the Detach Database window, select Drop Connections and click OK. 
(Selecting Drop Connections causes Sage Timberline Enterprise to close 
automatically on all workstations. All users should be logged out of the software 
before you do this.)

4. In Windows Explorer, browse to the database (.mdf and .ldf) files. Copy them 
to the new default data location.  (See “Determine the Location of Data and 
Shared Folders” on page 17 for help determining this location.)

5. At the new server, log on to SQL Server Management Studio (Start > 
Programs > Microsoft SQL Server 2008 > SQL Server Management 
Studio).

6. Right-click Databases and select Attach. Click Add, and add the database.
© 2010 Sage Software, Inc. 113



Move Sage Timberline Enterprise to a New Server Sage Timberline Enterprise
To Stop SQL Server Services and Copy the Database

1. At your current server, open SQL Server Configuration Manager (Start > 
Programs > Microsoft SQL Server 2008 > Configuration Tools > SQL 
Server Configuration Manager.)

2. Click SQL Server Services.

3. Right-click each of the services listed and select Stop. (This closes all 
connections to Sage Timberline Enterprise automatically. All users should be 
logged out.)

4. In Windows Explorer, browse to the database (.mdf and .ldf) files. Copy them 
to the new default data location.  (See “Determine the Location of Data and 
Shared Folders” on page 17 for help determining this location.)

5. At the new server, log on to SQL Server Management Studio (Start > 
Programs > Microsoft SQL Server 2008 > SQL Server Management 
Studio).

6. Right-click Databases and select Attach. Click Add, and add the database.

Deactivate Licenses on the Current Server
Before you can move Sage Timberline Enterprise to a new server, you must first 
deactivate the licenses on the existing server. If you are unable to access the original 
server due to a hardware failure, you must contact Sage customer support to have 
your server licenses deactivated.

1. Log on to the existing Sage Timberline Enterprise server using the Sage system 
administrator account.

2. Start Sage System Administration (Start > All Programs > Sage > Sage 
System Administration).

3. Select License Administration.

4. Click Restrict logon to prevent new users from logging on. This does not 
remove active users. If any users are currently active, ask them to close 
Sage Timberline Enterprise. When all users have logged off, continue with this 
procedure.

5. On the License information tab, click Deauthorize license server. You will 
receive a message that the server is no longer authorized. 

6. Click OK. 
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Install Remaining Software on the New Server
Complete the remaining installation tasks on the new server, referring to the pages 
listed for more information.

Install and configure Microsoft Internet Information Services on the server that 
will hold Sage Timberline Enterprise (page 43).

Install Sage Timberline Enterprise on the new server (page 47).

Install Payroll (optional, page 50).

Install Estimating and License Manager (optional, page 55).

Run the Sage System Administration Configuration Wizard (page 64).

Activate Your Sage Timberline Enterprise Licenses (page 71).

Configure Users in Sage System Administration
Complete this step if your new Sage Timberline Enterprise installation is on a 
different Windows domain than previously. Otherwise, proceed to “Test the New 
Installation.”

Before you can complete this step, all users must be added to Active Directory for 
the new domain.

1. At the new server, open Sage System Administration.

2. Click Database Administration. Note that the list of users is retained after you 
moved the database. However, if you moved your installation to the new 
domain, the domain listed for each user is incorrect.

3. Click the first user to select it. Click Add user, and add the corresponding user 
from the new domain.  Reassign this user to the necessary roles.

4. Click the original user, and click Remove user. Only the new user should 
remain.

5. Complete this procedure for each user associated with the database.

Test the New Installation 
To verify that the server migration was successful, follow this procedure.

1. At each workstation, select Start > All Programs > Sage > Sage Timberline 
Enterprise.

2. In the the Logon screen, enter your Windows password.

3. Verify that the new server and database are listed.

4. Click OK. Sage Timberline Enterprise should open successfully.
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Check for Software Updates
Periodically, Sage releases software updates that include items such as new features 
or updated Payroll tax files. You can download these updates automatically or 
manually from System Adminsitration, and can choose when you want to install 
them to your server. Once you install an update on the server, you can install it on 
the workstations.

NOTE:  You must complete this procedure at the server, and you must be logged on to 
Windows as a Sage Timberline Enterprise administrator. Although System Administration 
is installed on workstations, the Update Administration options are available only on the 
server.

Download and Install an Update

1. Back up your databases and other important files before you install an update. 
(See “Back Up Your Data.”)

2. Open System Administration (Start > All Programs > Sage > 
Sage System Administration).

3. Make sure that no workstations are connected to Sage Timberline Enterprise. 
You can see active users in System Administration by clicking License 
Administration and then clicking the Active Users tab. 

4. Click Restrict Logon to prevent any further connections.
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5. Click Update Administration. The appearance of the next window differs 
according to whether automatic downloads are enabled. (By default, automatic 
updates are enabled. Instructions to change this setting are on page 123, 
step 14.)

If automatic updates are enabled and updates are present, they are listed in 
this window. The top right button says Install Server and the status of the 
update is Ready to install server update.

If automatic updates are enabled but no updates are listed in the window, 
you can click Check to check for updates and download any that are found.
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If automatic updates are disabled, click Check to check for updates. 
Updates will be listed, but not downloaded. 

The top right button says Download, and the status of the update is Ready 
to download. Click Download to obtain the update.
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6. Once an update is downloaded, click the Details button to see the details of an 
update. 

From this window, you can click Update Folder to browse to the location of 
your updates.

7. Click OK to close the Details window.

8. Once updates are downloaded, select an update to install, and then click 
Install Server. 

NOTE:  All computers (servers and workstations) must have the same version of Sage 
Timberline Enterprise. When each workstation next connects to the server, a message is 
displayed indicating that the workstation needs to be updated. You can update the 
workstation at that time. You will not be able to use Sage Timberline Enterprise at a given 
workstation until the update is installed.

Configure Automatic Software Updates and Notification
You can configure System Administration to notify you automatically whenever an 
update to Sage Timberline Enterprise is available.

1. Open the System Administration (Start > All Programs > Sage > 
Sage System Administration).

2. Click Update Administration.
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3. Click the Settings tab, and then click the Email Notifications subtab. 

4. Click Add.

5. Add the e-mail address and select the type of emails you want to receive.

6. Click Add. The new e-mail address appears under Subscribers.

7. To test an e-mail address, under Settings, click Email.

8. Supply a valid email address, user name, and password. 
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9. Enter the information about your email server.

10. Click Send Test Email. A test email is sent to the account listed next to 
Email address.

11. Click the Frequency subtab. This tab lets you indicate how often the 
Installation Manager should check for new updates.
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12. Click Settings to specify the frequency. The default setting is Every 7 days.

13. Click OK, and then click the Downloads subtab. This tab lets you enable or 
disable automatic downloads.

14. Click Settings to change the download setting. The default setting is to 
automatically download updates.
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View Update History
1. Open the System Administration (Start > All Programs > Sage > 

Sage System Administration).

2. Click Update Administration, and then click the History tab. The page shows 
information about updates that have been downloaded or installed.
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Further Assistance
If you need further assistance with Sage Timberline Enterprise, these additional 
resources are available to you.

Additional documentation
The Sage Timberline Enterprise Release Notes provide additional information 
about the current release, including release features and any known issues. A 
current copy of the release notes is posted at:

http://customers.sagenorthamerica.com/irj/go/km/docs/sageKM/Assets/
Sage_Timberline_Enterprise_10.0_Release_Notes.pdf

If any important issues were found immediately prior to release that were not 
included in any of the release documentation, they will be described in an 
Important Document that is included in your installation materials. 

Support Knowledgebase
Access the Sage Knowledgebase 24 hours a day, 7 days a week, for answers to your 
questions about Sage Timberline Enterprise. It is available at:
https://customers.sagenorthamerica.com/irj/portal/anonymous/login.

Online Help
Each Sage Timberline Enterprise module includes online help, which provides 
answers to many of your questions. To use help, from the 
Sage Timberline Enterprise Desktop, select Help, and then choose the module for 
which you want further assistance. 

More often, you will want to access the help links in the various 
Sage Timberline Enterprise windows. Press F1 at any point to display the help 
topics for that window.

Each help project includes a full table of contents that describes the features and 
functions of the module. The help also includes index and search capability so you 
can find the information you need. For more information on using the help system, 
see Sage Timberline Enterprise Desktop help (in the Desktop, select Help > Sage 
Timberline Enterprise Desktop Help). 

Each help topic displays a help feedback section, where you are invited to tell us 
whether the topic was helpful, and to provide additional comments to assist us in 
improving our help system. 
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Enroll in Training Classes
Sage University offers online training sessions to help you get the most out of your 
Sage Timberline Enterprise software. To access Sage University, from the 
Sage Timberline Enterprise Desktop, select Help > Sage Timberline Enterprise 
on the Web > Sage Software University or visit www.sageu.com.

Contact Customer Support
If your service plan provides online customer support, you can contact us through 
the Web:

1. Log on to https://customers.sagenorthamerica.com/irj/portal/anonymous/
login. 

2. Click Support > Self Service. 

3. On the My Requests tab under Create, click Customer Support Ticket. 

4. Complete the form to submit a support ticket directly to Customer Support.

Telephone Support

If your service plan provides telephone assistance and you prefer to speak to 
Customer Support, call us at 800-866-8049. Our hours are Monday through Friday 
from 6 a.m. to 5 p.m. Pacific Time.

Upgrade Your Service Plan

If your service plan does not provide online or telephone customer support and you 
would like to add or upgrade a service plan:

1. Call 800-991-5606, or log on to https://customers.sagenorthamerica.com/
irj/portal/anonymous/login.

2. Select Anonymous Portal Access on right. 

3. Click Support > Self Service. 

4. On the My Requests tab under Create, click Customer Service Request. 

5. Complete the form to submit a service request.

Submit Enhancement Requests
We want to hear your suggestions for improving the software. To send us your 
comments, select Help > Sage Timberline Enterprise on the Web >Submit 
Enhancement Request.
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